Log in
Fixed an issue introduced in v1587 where in certain environments, jobs would not fail properly, and continued to be marked as running.
For HashiCorp Vault secrets managers, added support for LDAP authentication.
Amazon Redshift - Added support for subsetting for workspaces that use the Data Pipeline V2 data generation process.
Amazon Redshift - Added support to run data generation using the Data Pipeline V2 process, which does not require the AWS Lambda infrastructure. For Amazon Redshift workspaces, the Confirm Generation panel now provides an option to select whether to use the classic data generation or Data Pipeline V2.
Oracle: NUMBER(*,scale) columns now force the use of Sql*Loader instead of the faster BulkCopy.
When sharing a workspace or changing the shared permissions, users cannot grant or revoke access to revoke permissions that they do not have for the workspace. For example, if your assigned permission set for a workspace does not include the Run data generation permission, then you cannot assign or remove a workspace permission set that includes the Run data generation permission.
PostgreSQL - Fixed an error that could occur when tearing down a destination database that contained a very large number of Large Objects.
MongoDB - Fixed an issue that prevented data generation or schema diff execution when the workspace contained a schema change in a foreign key column that had an applied generator.
Subsetting no longer revisits lookup tables during the subset traversal. The lookup table is downloaded immediately as a direct target, and no further passes are made.
Snowflake - Fixed handling of schemas that use various constraint options in their table definitions.
Fixed an issue where OutOfMemoryException could be thrown when JSON data contained arrays larger than 2GB.
MongoDB and Document View: You can use path expressions to protect unscanned fields. If a path expression generator applies to an unscanned field, data generation does not fail and the generator is used to mask the field value.
To use this feature for MongoDB, set the environment setting TONIC_MONGO_DISABLE_FIELD_PROJECTION to true. Otherwise, unscanned fields are skipped automatically during data generation. Note that when this setting is true, any unscanned field that is not protected by a path expression generator causes data generation to fail.
Adjusted the Timestamp Shift generator output when the generator is configured to use self-consistency:
Date-only values that represent the same logical date shift consistently
For all types, the preview values in Table View are now more consistently aligned with the generated values
This change might affect the consistency of values for existing generator assignments.